Cannot connect to Windows 7 SMB shares from XP/2003
2 dicembre 2013
If you try to connect to a Windows 7 share from Windows XP or Server 2003 and get a «System Error 58», you can use the following solution.
The problem is that Windows 7 uses NTLMv2, while XP and 2003 use LM & NTLM. To resolve the issue, do the following on the Windows 7 computer:
- Run
gpedit.msc. - Expand Computer Configuration → Windows Settings → Security Settings → Local Policies → Security Options.
- Open the properties of Network security: LAN Manager authentication level.
- Set the value to Send LM & NTLM – use NTLMv2 session security if negotiated.
- Run
services.mscand restart the Server service.
You can now map your drive from the XP/2003 box to the Windows 7 computer.